Taiko Alpha-3/4 Testnet [Ended]

Testnet 3 just went live!

Announcement over on twitter here: https://twitter.com/taikoxyz/status/1666429573737877505

It will be interesting to see how this alpha-3 testnet goes, especially given this one will likely be longer than the month-long alpha-2 previously.

Guides/info here: https://taiko.xyz/docs/guides

62 Likes

… failed to bridge again and again …

7 Likes

Yes, there will be times of instability. Its just an alpha testnet afterall.

I had a stack of bridge failures while I was going through the initial wallet setup steps. Just leave it for a bit and come back to it, it all works eventually :slightly_smiling_face:

8 Likes

Thank you sir, I was patient during the first test in march and April, too :slight_smile:

5 Likes


done

3 Likes

i run a prover ,but get something wrong。

simple-taiko-node-taiko_client_driver-1 | ERROR[06-09|02:19:10.306] Block batch iterator callback error error=“failed to insert new head to L2 execution engine: missing trie node 28cfcadce89d83f0d0f543a760ab476f3aa571677c6bf9641d081b7757d508b6 (path ) ”

1 Like

Does anyone have a solution

1 Like

Are you on the discord @rootter ?
There is a developer chat section there, which should be able to offer support for technical things. (or throw it into general perhaps). Hope you can get it sorted, goodluck

1 Like

I bridged ETH, BLL, HORSE from Sepholia to Taiko-3. Did some swaps, entered pools. Everything is working good!

The only question I have is: why I have to claim tokens on Taiko after bridging from Sepholia? Does not it happen automatically?

3 Likes

fail to claim BULL tokens after bridging.
moved ETH HORSE and BULL from Sepolia to Taiko well
and HORSE back from Taiko to Sepolia, but cannot claim BULL after bridging from Taiko.
tap “claim” allow transaction in MM, pay gas, see “claimed”, see 0 BULL in Sepolia, reload the bridge page, see “retry”. Tried 6 or 7 times, no success
And yes, it is quite unusual that i had to pay gas 2 times - when initiate transaction and when claim tokens in destination network. I used to pay once at another bridges, and did not need to claim

oh, well. finaly claimed, made tons of screenshot for proofs and then after 8th or 9th attempt have seen BULLS in wallet

1 Like

Amazing piece . I enjoyed reading this

3 Likes

very smooth more than alpha 1 & 2

2 Likes

Worth noting here: We’re approaching 2 weeks into the Alpha-3 testnet, and the price to TTKO has dropped substantially. Supply and demand at work! Provers had TTKO distributed to them, and at the same time they are earning TTKO for generating proofs - the supply increases - cost decreases.

TTKO has been distributed to all proposers and provers from the alpha-1 and alpha-2 testnets. Check your address balance on Sepolia. Currently, the only other way to receive TTKO is by successfully generating proofs on alpha-3 testnet, for which the protocol rewards you in TTKO.
Receive tokens – Taiko

So if anyone is wanting to run a proposer for example, but doesnt have the TTKO on hand (and didnt receive it due to not being here for alpha-1 or alpha-2) then its probably a safe bet TTKO will become easier to acquire soon. So maybe later in this testnet becoming a proposer will be a bit easier for a lot of us not here during earlier alphas.

And something else worth considering here: If there is a regeneration of the testnet - I am not sure if everyones TTKO balances will remain. So this could be a tricky game of guessing when TTKO prices are cheap enough vs still allowing time for provers to get up and running before any network resets take place. Something to keep in mind as this is a testnet, so resets can take place and its hard to say exactly what impact that will have (we will find out in time I am sure).

2 Likes

Been trying to verify a contract after deploying to Taiko 3 in remix?? Anyone done this successfully, can share his experience. Thanks :pray:

2 Likes

Developer chat on the discord is probably your best bet for support/debugging @Nedior, not a whole lot of traffic here (especially for debugging such specific issues)

2 Likes

Bridge BLL token failed .

1 Like

hi team, i swap sepeth to ttko on taiko testnet and hope to a proposer on alpha3 testnet, but i did not see my ttko token in my wallet, may i know why?

1 Like

@KID is TTKO not displaying in your wallet at all? If so, then youll need to configure it to show up (ie Metamask wont show tokens unless you manually configure it) Configure your wallet – Taiko

Or if the token is showing up in your wallet, but is showing as ‘0’ - then your swap likely failed. I’d see if theres some record of the swap to see if there was an error or something you did incorrectly there. I have had swaps fail, it can take a few attempts as this is a testnet which will glitch at times.

@hotrung - BLL will fail a lot of the time. Give it a few more shots and it should work eventually. If its not working today, try again another day as the network might just be glitching out overall some days.

5 Likes

thanks alex, it shows now and may i use it to run a proposer node?

3 Likes

Great to hear!

And yes that will assist you in proposing blocks.
I see people on the discord mentioning its between 5-10 TTKO to propose a block right now - fyi.

1 Like